blob: a4d67cd2ceeb6641b0d5d5700773f0aaaafff159 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Keyboard configuration database for X Window"
2
3DESCRIPTION = "The non-arch keyboard configuration database for X \
4Window. The goal is to provide the consistent, well-structured, \
5frequently released open source of X keyboard configuration data for X \
6Window System implementations. The project is targeted to XKB-based \
7systems."
8
9HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
10BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
11
12LICENSE = "MIT & MIT-style"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
14
Andrew Geissler5a43b432020-06-13 10:46:56 -050015SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2"
16SRC_URI[sha256sum] = "095a524f7b633ed257617202d06c9c71fe020c8897b106cf0dcdd0c6e8b797d4"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18SECTION = "x11/libs"
19DEPENDS = "util-macros libxslt-native"
20
21EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
22
23FILES_${PN} += "${datadir}/X11/xkb"
24
25inherit autotools pkgconfig gettext
26
27do_install_append () {
28 install -d ${D}${datadir}/X11/xkb/compiled
29 cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
30}