blob: fd57f8f7f0aeb935cf1b63de414214c0ee5ca36b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
2DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
3bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
4and copying files using the block map. The idea is that large file containing \
5unused blocks, like raw system image files, can be copied or flashed a lot \
6faster with bmaptool than with traditional tools like "dd" or "cp"."
7HOMEPAGE = "https://github.com/01org/bmap-tools"
8SECTION = "console/utils"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12SRC_URI = "git://github.com/intel/${BPN}"
13
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050014SRCREV = "a17f0e3ff8669dd3b1c44a741ae4f8162155faed"
Brad Bishop19323692019-04-05 15:28:33 -040015S = "${WORKDIR}/git"
16PV .= "+git${SRCPV}"
17
18UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
19
20RDEPENDS_${PN} = "python3-core python3-compression python3-mmap python3-setuptools python3-fcntl python3-six"
21
22inherit python3native
23inherit setuptools3
24
Andrew Geissler5a43b432020-06-13 10:46:56 -050025BBCLASSEXTEND = "native nativesdk"