blob: d6425bd941f322609a823980c98ea6c0f279a6c4 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "An HTTP library implementation in C"
2HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome/libs"
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native libpsl"
9
10SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
11
12SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050013SRC_URI[md5sum] = "c539f5b5ab534f024dc4e6a14e6d3f54"
14SRC_URI[sha256sum] = "54b020f74aefa438918d8e53cff62e2b1e59efe2de53e06b19a4b07b1f4d5342"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
16CVE_PRODUCT = "libsoup"
17
18S = "${WORKDIR}/libsoup-${PV}"
19
20inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
21
22GIR_MESON_ENABLE_FLAG = 'enabled'
23GIR_MESON_DISABLE_FLAG = 'disabled'
24
25# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
26PACKAGECONFIG ??= ""
27PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false"
28PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5"
29
30EXTRA_OEMESON_append = " -Dvapi=disabled -Dtls_check=false"
31
32GTKDOC_MESON_OPTION = "gtk_doc"
33
34# When built without gnome support, libsoup-2.4 will contain only one shared lib
35# and will therefore become subject to renaming by debian.bbclass. Prevent
36# renaming in order to keep the package name consistent regardless of whether
37# gnome support is enabled or disabled.
38DEBIAN_NOAUTONAME_${PN} = "1"
39
40# glib-networking is needed for SSL, proxies, etc.
41RRECOMMENDS_${PN} = "glib-networking"
42
Andrew Geissler5a43b432020-06-13 10:46:56 -050043BBCLASSEXTEND = "native nativesdk"