blob: 1c17c0065613d74b2cbc4967bfe7e498bbe46adc [file] [log] [blame]
Jeremy Kerr708f0cc2019-12-20 12:02:36 +08001SUMMARY = "MCTP stack"
2DESCRIPTION = "MCTP library implementing the MCTP base specification"
Jeremy Kerr708f0cc2019-12-20 12:02:36 +08003HOMEPAGE = "https://github.com/openbmc/libmctp"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=0d30807bb7a4f16d36e96b78f9ed8fae"
Jeremy Kerr708f0cc2019-12-20 12:02:36 +08006DEPENDS += "autoconf-archive-native \
7 systemd \
George Liu948c7b42021-06-24 11:13:15 +08008 "
Andrew Geissler5aa778d2023-01-16 19:50:24 -06009SRCREV = "45d1332818c13df182242a8cb80cbe9f983fd057"
Ed Tanous9936f862022-09-19 09:13:20 -070010PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} pcap"
11PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, \
12 --without-systemdsystemunitdir,systemd"
13PACKAGECONFIG[astlpc-raw-kcs] = "--enable-astlpc-raw-kcs,--disable-astlpc-raw-kcs,udev,udev"
14PACKAGECONFIG[pcap] = "--enable-capture,--disable-capture,libpcap,"
15PV = "1.0+git${SRCPV}"
16PR = "r1"
17
18SRC_URI = "git://github.com/openbmc/libmctp;branch=master;protocol=https \
19 file://default"
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080020
Patrick Williams12fc9392021-08-06 09:16:53 -050021SYSTEMD_SERVICE:${PN} = "mctp-demux.service \
George Liu948c7b42021-06-24 11:13:15 +080022 mctp-demux.socket \
23 "
Ed Tanous9936f862022-09-19 09:13:20 -070024S = "${WORKDIR}/git"
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080025
Ed Tanous9936f862022-09-19 09:13:20 -070026inherit systemd
27inherit autotools pkgconfig
Andrew Jefferyd957f032021-05-12 22:31:34 +093028
Patrick Williams12fc9392021-08-06 09:16:53 -050029do_install:append() {
Ed Tanous9936f862022-09-19 09:13:20 -070030 install -d ${D}${sysconfdir}/default
31 install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/mctp
Jeremy Kerr708f0cc2019-12-20 12:02:36 +080032}
33
Ed Tanous9936f862022-09-19 09:13:20 -070034CONFFILES:${PN} = "${sysconfdir}/default/mctp"