blob: 12912e29a34411721e540d926724ac55be1f3f93 [file] [log] [blame]
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05301SUMMARY = "Phosphor User Manager Daemon"
2DESCRIPTION = "Daemon that does user management"
3HOMEPAGE = "http://github.com/openbmc/phosphor-user-manager"
4PR = "r1"
Patrick Venture4f792732018-10-02 20:51:15 -07005PV = "1.0+git${SRCPV}"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05306LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Patrick Venture4f792732018-10-02 20:51:15 -07008
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05309inherit autotools pkgconfig
10inherit obmc-phosphor-dbus-service
11
Anton D. Kachalov31ecbfb2021-04-21 19:23:55 +020012DEPENDS += "dbus"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053013DEPENDS += "autoconf-archive-native"
14DEPENDS += "sdbusplus"
15DEPENDS += "phosphor-logging"
16DEPENDS += "phosphor-dbus-interfaces"
Tom Joseph926556d2018-07-10 12:23:06 -050017DEPENDS += "boost"
Andrew Geissler1de95de2018-10-09 04:10:28 +000018DEPENDS += "nss-pam-ldapd"
Brad Bishop44f3cce2019-03-22 23:41:42 -040019DEPENDS += "systemd"
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050020PACKAGE_BEFORE_PN = "phosphor-ldap"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053021
Richard Marian Thomaiyara3488602018-04-12 16:06:36 -070022inherit useradd
23
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050024USERADD_PACKAGES = "${PN} phosphor-ldap"
25DBUS_PACKAGES = "${USERADD_PACKAGES}"
Richard Marian Thomaiyara3488602018-04-12 16:06:36 -070026# add groups needed for privilege maintenance
Patrick Williams12fc9392021-08-06 09:16:53 -050027GROUPADD_PARAM:${PN} = "priv-admin; priv-operator; priv-user "
28GROUPADD_PARAM:phosphor-ldap = "priv-admin; priv-operator; priv-user "
Richard Marian Thomaiyar7a8e9b22018-12-14 09:04:40 +053029
Patrick Williams12fc9392021-08-06 09:16:53 -050030DBUS_SERVICE:${PN} += "xyz.openbmc_project.User.Manager.service"
31FILES:phosphor-ldap += " \
Patrick Ventured8014ce2019-04-04 10:03:09 -070032 ${bindir}/phosphor-ldap-conf \
33 ${bindir}/phosphor-ldap-mapper \
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050034"
Anton D. Kachalov31ecbfb2021-04-21 19:23:55 +020035FILES:${PN} += " \
36 ${base_libdir}/systemd \
37 ${datadir}/phosphor-certificate-manager \
38"
Patrick Williams12fc9392021-08-06 09:16:53 -050039DBUS_SERVICE:phosphor-ldap = " \
Tom Joseph42276262018-10-07 05:51:04 -050040 xyz.openbmc_project.Ldap.Config.service \
41 xyz.openbmc_project.LDAP.PrivilegeMapper.service \
42"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053043SRC_URI += "git://github.com/openbmc/phosphor-user-manager"
Andrew Geissler5ac031f2021-10-04 14:51:41 +000044SRCREV = "372c5668c0ed893f53edc0f9fa880cb50b48f203"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053045S = "${WORKDIR}/git"