Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "nl80211 based CLI configuration utility for wireless devices" |
| 2 | DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \ |
| 3 | wireless devices. It supports almost all new drivers that have been added \ |
| 4 | to the kernel recently. " |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 5 | HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | SECTION = "base" |
| 7 | LICENSE = "BSD-2-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774" |
| 9 | |
| 10 | DEPENDS = "libnl" |
| 11 | |
| 12 | SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \ |
| 13 | file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \ |
| 14 | file://separate-objdir.patch \ |
| 15 | " |
| 16 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 17 | SRC_URI[sha256sum] = "6e7d3c9f8b4ee68e412f20fe229c9854c2dba383e3e650ce6af8eb8dbd12efc3" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
| 19 | inherit pkgconfig |
| 20 | |
| 21 | EXTRA_OEMAKE = "\ |
| 22 | -f '${S}/Makefile' \ |
| 23 | \ |
| 24 | 'PREFIX=${prefix}' \ |
| 25 | 'SBINDIR=${sbindir}' \ |
| 26 | 'MANDIR=${mandir}' \ |
| 27 | " |
| 28 | |
| 29 | do_install() { |
| 30 | oe_runmake 'DESTDIR=${D}' install |
| 31 | } |