blob: ae0078bacbce3846a94c6a496ce3c204274bd6db [file] [log] [blame]
Brad Bishop5baa96f2015-11-18 10:56:38 -05001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
Brad Bishop39beab92018-06-06 16:16:23 -04002SRC_URI += "file://0001-json-Use-int-long.__str__-to-convert-subclasses.patch"
Brad Bishop5baa96f2015-11-18 10:56:38 -05003
Andrew Geissleracdd46d2018-08-29 06:06:42 -07004# Remove all python .py files from python recipe. Only the .pyc
5# files are required. Only do this if the openbmc-phosphor-tiny
6# distro feature is enabled
7do_install_append_openbmc-phosphor-tiny() {
Andrew Geissler37db84e2018-09-25 09:32:31 -05008 # The _sysconfigdata.py is a system configuration file generated
9 # during build time. It's used in the yocto packaging process so
10 # it is required to remain in the image.
11 find ${D}${libdir}/python${PYTHON_MAJMIN} -name \*.py ! -name _sysconfigdata.py -exec rm {} \;
Andrew Geissleracdd46d2018-08-29 06:06:42 -070012}