blob: 21fd7e93e2eeef01b6b6483fb5dc2ac0bf4590ed [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "1-Wire file system"
2DESCRIPTION = "OWFS is an easy way to use the powerful 1-wire system of Dallas/Maxim"
3HOMEPAGE = "http://www.owfs.org/"
4SECTION = "console/network"
5
6LICENSE = "GPLv2 & LGPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=a0bc427f423a41220ab79a0b392218bd \
8 file://COPYING.LIB;md5=865c4bd642d9e04f43925ad7e929ae87"
9
10DEPENDS = "fuse virtual/libusb0"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/owfs/owfs-${PV}.tar.gz \
13 file://owhttpd \
14 file://owserver "
15SRC_URI[md5sum] = "56ba145be208002e58775a7203369851"
16SRC_URI[sha256sum] = "9d22dbff72d235476688c02669f7171b23e21dffadf40bbdd3b8263908218424"
17
18inherit autotools-brokensep update-rc.d
19
20EXTRA_OECONF = " \
21 --with-fuseinclude=${STAGING_INCDIR} \
22 --with-fuselib=${STAGING_LIBDIR} \
23 --enable-owfs \
24 --enable-owhttpd \
25 --enable-w1 \
26 --disable-swig \
27 --disable-owtcl \
28 --disable-owphp \
29 --disable-owpython \
30 --disable-owperl \
31"
32
33do_install_prepend() {
34 install -d ${D}${sysconfdir}/default/
35 install -d ${D}${sysconfdir}/init.d/
36 install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd
37 install -m 0755 ${WORKDIR}/owserver ${D}${sysconfdir}/init.d/owserver
38}
39
40PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap"
41
42DESCRIPTION_owftpd = "Anoymous FTP server for 1-wire access"
43DESCRIPTION_owhttpd = "Tiny webserver for 1-wire control"
44DESCRIPTION_owserver = "Backend server (daemon) for 1-wire control"
45DESCRIPTION_owshell = "owdir owread owwrite owpresent owget - lightweight owserver access"
46DESCRIPTION_libowcapi = "easy C-language 1-wire interface "
47DESCRIPTION_libow = "easy C-language 1-wire interface to the owserver protocol"
48DESCRIPTION_libownet = "easy C-language 1-wire interface to the owserver protocol"
49DESCRIPTION_owmon = "Monitor for owserver settings and statistics"
50DESCRIPTION_owtap = "Packet sniffer for the owserver protocol"
51
52FILES_owftpd = "${bindir}/owftpd"
53FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd"
54FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver"
55FILES_owshell = "${bindir}/owread ${bindir}/owwrite \
56 ${bindir}/owdir ${bindir}/owpresent \
57 ${bindir}/owget ${bindir}/owside"
58FILES_owmon = "${bindir}/owmon"
59FILES_owtap = "${bindir}/owtap"
60FILES_libowcapi = "${libdir}/libowcapi-*"
61FILES_libow = "${libdir}/libow-*"
62FILES_libownet = "${libdir}/libownet-*"
63
64INITSCRIPT_PACKAGES = "owhttpd owserver"
65INITSCRIPT_NAME_owserver = "owserver"
66INITSCRIPT_NAME_owhttpd = "owhttpd"
67INITSCRIPT_PARAMS_owserver = "defaults 20"
68INITSCRIPT_PARAMS_owhttpd = "defaults 21"