blob: 1eb9b70077062d6dddcf875b9e19f104b40f2ddc [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Implementation of a fully functional filesystem in a userspace program"
2DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
3 programs to export a virtual filesystem to the Linux kernel. FUSE \
4 also aims to provide a secure method for non privileged users to \
5 create and mount their own filesystem implementations. \
6 "
7HOMEPAGE = "https://github.com/libfuse/libfuse"
8SECTION = "libs"
9LICENSE = "GPLv2 & LGPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
11 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
12
13SRC_URI = "https://github.com/libfuse/libfuse/releases/download/${BP}/${BP}.tar.gz \
14 file://gold-unversioned-symbol.patch \
15 file://aarch64.patch \
16 file://0001-fuse-fix-the-return-value-of-help-option.patch \
17 file://fuse.conf \
Armin Kuster066be202018-07-08 14:58:53 -070018 file://CVE-2018-10906-1.patch \
19 file://CVE-2018-10906-2.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020"
21SRC_URI[md5sum] = "9bd4ce8184745fd3d000ca2692adacdb"
22SRC_URI[sha256sum] = "832432d1ad4f833c20e13b57cf40ce5277a9d33e483205fc63c78111b3358874"
23
24inherit autotools pkgconfig update-rc.d systemd
25
26INITSCRIPT_NAME = "fuse"
27INITSCRIPT_PARAMS = "start 3 S . stop 20 0 6 ."
28
29SYSTEMD_SERVICE_${PN} = ""
30
31DEPENDS = "gettext-native"
32
33PACKAGES =+ "fuse-utils-dbg fuse-utils libulockmgr libulockmgr-dev libulockmgr-dbg"
34
35RRECOMMENDS_${PN}_class-target = "kernel-module-fuse libulockmgr fuse-utils"
36
37FILES_${PN} += "${libdir}/libfuse.so.*"
38FILES_${PN}-dev += "${libdir}/libfuse*.la"
39
40FILES_libulockmgr = "${libdir}/libulockmgr.so.*"
41FILES_libulockmgr-dev += "${libdir}/libulock*.la"
42FILES_libulockmgr-dbg += "${libdir}/.debug/libulock*"
43
44# Forbid auto-renaming to libfuse-utils
45FILES_fuse-utils = "${bindir} ${base_sbindir}"
46FILES_fuse-utils-dbg = "${bindir}/.debug ${base_sbindir}/.debug"
47DEBIAN_NOAUTONAME_fuse-utils = "1"
48DEBIAN_NOAUTONAME_fuse-utils-dbg = "1"
49
50do_configure_prepend() {
51 # Make this explicit so overriding base_sbindir propagates properly.
52 export MOUNT_FUSE_PATH="${base_sbindir}"
53}
54
55do_install_append() {
56 rm -rf ${D}${base_prefix}/dev
57
58 # systemd class remove the sysv_initddir only if systemd_system_unitdir
59 # contains anything, but it's not needed if sysvinit is not in DISTRO_FEATURES
60 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'false', 'true', d)}; then
61 rm -rf ${D}${sysconfdir}/init.d/
62 fi
63
64 # Install systemd related configuration file
65 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
66 install -d ${D}${sysconfdir}/modules-load.d
67 install -m 0644 ${WORKDIR}/fuse.conf ${D}${sysconfdir}/modules-load.d
68 fi
69}
70
71BBCLASSEXTEND = "native nativesdk"