blob: 39f11890e1691d3b0689c006761e36dc4f667548 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "XFS Filesystem Dump Utility"
2DESCRIPTION = "The xfsdump package contains xfsdump, xfsrestore and a \
3 number of other utilities for administering XFS filesystems.\
4 xfsdump examines files in a filesystem, determines which \
5 need to be backed up, and copies those files to a \
6 specified disk, tape or other storage medium."
7HOMEPAGE = "http://oss.sgi.com/projects/xfs"
8SECTION = "base"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://doc/COPYING;md5=15c832894d10ddd00dfcf57bee490ecc"
11DEPENDS = "xfsprogs attr"
12
13SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsdump/${BP}.tar.xz \
14 file://remove-install-as-user.patch \
15 file://0001-Include-fcntl.h-for-O_EXCL.patch \
16 file://0002-Replace-__uint32_t-with-uint32_t.patch \
17 file://0003-replace-use-of-SIGCLD-with-SIGCHLD.patch \
18 file://0004-include-limit.h-for-PATH_MAX.patch \
19 file://0005-include-sys-types.h-for-u_int32_t-in-attr-attributes.patch \
20 file://0001-xfsdump-Use-c99-defined-int64_t-instead-of-__int64_t.patch \
21 "
22SRC_URI[md5sum] = "c6e91f2ac8b76c796db2d236f5ca5947"
23SRC_URI[sha256sum] = "99e6d4df257ebc6d29ca9e970ca20672c2ea03481ad949bc68f98de3e4d56dce"
24
25inherit autotools-brokensep
26
27PARALLEL_MAKE = ""
28PACKAGECONFIG ??= ""
29PACKAGECONFIG[gettext] = "--enable-gettext=yes,--enable-gettext=no,gettext"
30
31CFLAGS += "-D_FILE_OFFSET_BITS=64"
32
33EXTRA_OEMAKE += "'LIBTOOL=${HOST_SYS}-libtool' V=1"
34
35do_configure () {
36 export DEBUG="-DNDEBUG"
Brad Bishop316dfdd2018-06-25 12:45:53 -040037 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
38 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039 oe_runconf
40}
41
42do_install () {
43 export DIST_ROOT=${D}
44 oe_runmake install
45 oe_runmake install-dev
46}