blob: 48fc9144dc27a139f50950c5dca7ee03e4329291 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SECTION = "x11/wm"
2SUMMARY = "Metacity is the boring window manager for the adult in you"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b4cce53560b8e619ffa7c830fb8761aa \
5 file://src/include/main.h;endline=24;md5=72148ede07a6dadd01de6a882d20a9ad"
6
7DEPENDS = "gsettings-desktop-schemas startup-notification \
8 gnome-doc-utils gdk-pixbuf-native \
9 gtk+3 glib-2.0 libcanberra libgtop intltool-native"
10
11inherit autotools gettext gnomebase distro_features_check
12# depends on startup-notification which depends on virtual/libx11
13REQUIRED_DISTRO_FEATURES = "x11"
14
15SRC_URI = "git://github.com/GNOME/metacity.git;branch=master \
16 file://0001-drop-zenity-detection.patch \
17"
18
19S = "${WORKDIR}/git"
20SRCREV = "c0d4b2fc0fcd6f2d3c37da935923f9e9ed5eb99f"
21
22EXTRA_OECONF += "--disable-xinerama"
23
24do_configure_prepend() {
25 cd ${S}
26 aclocal --install || exit 1
27 autoreconf --verbose --force --install -Wno-portability || exit 1
28 cd -
29
30}
31
32FILES_${PN} += "${datadir}/themes ${datadir}/gnome-control-center ${datadir}/gnome"
33RDEPENDS_${PN} += "gsettings-desktop-schemas"
34