blob: 66b95db00ffb6e01ab7954bd0ba3867e4c222329 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "TinyALSA is a small library to interface with ALSA in \
2the Linux kernel. It is a lightweight alternative to libasound."
3HOMEPAGE = "https://github.com/tinyalsa/tinyalsa"
4SECTION = "libs/multimedia"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://NOTICE;md5=dbdefe400d894b510a9de14813181d0b"
8
9S = "${WORKDIR}/git"
10SRCREV = "df11091086b56e5fb71887f2fa320e1d2ffeff58"
11SRC_URI = "git://github.com/tinyalsa/tinyalsa.git;protocol=https;"
12
13do_configure() {
14 :
15}
16
17do_compile() {
18 oe_runmake CC='${CC}' LD='${CC}' AR='${AR}'
19}
20
21do_install() {
22 oe_runmake install \
23 PREFIX="${prefix}" DESTDIR="${D}" INCDIR="${includedir}/tinyalsa" \
24 LIBDIR="${libdir}" BINDIR="${bindir}" MANDIR="${mandir}"
25}
26
27PACKAGES =+ "${PN}-tools"
28FILES_${PN}-tools = "${bindir}/*"