blob: 3dbc8b13e545ca66ef5d31a053a54ddd9c58a126 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001#
2# Copyright (C) 2012 Wind River Systems, Inc.
3#
4SUMMARY = "Provides a wrapper in Python to LDAP"
5DESCRIPTION = "This module provides access to the LDAP \
6(Lightweight Directory Access Protocol) through Python operations \
7instead of C API. The module mainly acts as a wrapper for the \
8OpenLDAP 2.x libraries. Errors will appear as exceptions."
9
10LICENSE = "PSF"
11HOMEPAGE = "http://www.python-ldap.org/"
12DEPENDS = "python openldap cyrus-sasl"
13
14PYPI_PACKAGE = "python-ldap"
15inherit pypi setuptools
16
17LIC_FILES_CHKSUM = "file://LICENCE;md5=a41c82edffa04912007cae1d20cac555"
18SRC_URI[md5sum] = "18db2d009150ec1864710fea3ed76173"
19SRC_URI[sha256sum] = "6d430ecf040f2fc704ee316d3390cb1f5419c191371e1e131baef54a0e42cef0"
20
21do_configure_prepend() {
22 sed -i -e 's:^library_dirs =.*::' setup.cfg
23 sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' setup.cfg
24}
25
26RDEPENDS_${PN} = " \
27 ${PYTHON_PN}-pprint \
28 ${PYTHON_PN}-threading \
29"