blob: 31e411e86d16b0ac463cb33f63d4be964d7fa9a3 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "dlm control daemon and tool"
2
3SECTION = "utils"
4HOMEPAGE = "https://fedorahosted.org/cluster/wiki/HomePage"
5
6REQUIRED_DISTRO_FEATURES = "systemd"
7
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008SRC_URI = "https://git.fedorahosted.org/cgit/dlm.git/snapshot/${BP}.tar.xz \
9 file://respect-ldflags-also-from-bin_ldflags.patch \
10"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
12SRC_URI[md5sum] = "efc2ee6093aa6aa0a88aaad83e998a3f"
13SRC_URI[sha256sum] = "b89bc557aaffbab0ac005398025f247718a5589cff6574d902eaffe2b20e683e"
14
15LICENSE = "LGPLv2+ & GPLv2 & GPLv2+"
16LIC_FILES_CHKSUM = "file://README.license;md5=8f0bbcdd678df1bce9863492b6c8832d"
17
18DEPENDS = "corosync systemd"
19
20inherit pkgconfig systemd distro_features_check
21
22SYSTEMD_SERVICE_${PN} = "dlm.service"
23SYSTEMD_AUTO_ENABLE = "enable"
24
25export EXTRA_OEMAKE = ""
26
27do_compile_prepend() {
28 sed -i "s/libsystemd-daemon/libsystemd/g" ${S}/dlm_controld/Makefile
29}
30
31do_compile () {
32 oe_runmake 'CC=${CC}'
33}
34
35do_install_append (){
36 install -d ${D}${sysconfdir}/sysconfig/
37 install -d ${D}${sysconfdir}/init.d/
38 install -m 0644 ${S}/init/dlm.sysconfig ${D}${sysconfdir}/sysconfig/dlm
39 install -m 0644 ${S}/init/dlm.init ${D}${sysconfdir}/init.d/dlm
40
41 # install systemd unit files
42 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
43 install -d ${D}${systemd_unitdir}/system
44 install -m 0644 ${S}/init/dlm.service ${D}${systemd_unitdir}/system
45 fi
46}
47
48do_install() {
49 oe_runmake install DESTDIR=${D} LIBDIR=${libdir}
50}
51