blob: 1d77891d47786508ad71e8db9b8406daa279387e [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "OpenSource WebSocket Toolkit"
2DESCRIPTION = "noPoll is a OpenSource WebSocket implementation (RFC 6455), \
3written in ansi C, that allows building pure WebSocket solutions or to \
4provide WebSocket support to existing TCP oriented applications.\
5\
6noPoll provides support for WebSocket (ws://) and TLS (secure) WebSocket (wss://),\
7allowing message based (handler notified) programming or stream oriented access."
8
9HOMEPAGE = "http://www.aspl.es/nopoll/"
10LICENSE = "LGPL-2.1"
11LIC_FILES_CHKSUM = "file://COPYING;md5=f0504124678c1b3158146e0630229298 \
12 "
13DEPENDS = "openssl"
14SRC_URI = "http://www.aspl.es/nopoll/downloads/nopoll-${PV}.tar.gz \
15 "
16SRC_URI[md5sum] = "8c411cd0f3c0479aed28c4cf7b114fbb"
17SRC_URI[sha256sum] = "f5fbf8aaa16a77b0f265d8c847eb06cb3e68f2b1a50737466dae81181618654c"
18
19inherit autotools pkgconfig
20
21EXTRA_OECONF += "--disable-nopoll-doc"
22
23LDFLAGS += "-lpthread"