blob: c91b221b1e2717d4200d9da11d9d16d531df8f9a [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://tevent.samba.org"
3SECTION = "libs"
4LICENSE = "LGPLv3+"
5
6DEPENDS += "libtalloc libtirpc"
7RDEPENDS_python-tevent = "python"
8
9SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
10 file://options-0.9.36.patch \
11"
12LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=4e458d658cb25e21efc16f720e78b85a"
13
14SRC_URI[md5sum] = "87d67bca75b231814435c47bec0aff8a"
15SRC_URI[sha256sum] = "bd2b6be3fd1601ed7f176e99111e322c57d58e425cc149ee80c7dd4fed263b4c"
16
17inherit waf-samba
18
19PACKAGECONFIG ??= "\
20 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
21 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
22"
23PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
24PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
25PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
26PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
27PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
28PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
29
30SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
31
32S = "${WORKDIR}/tevent-${PV}"
33
34EXTRA_OECONF += "--disable-rpath \
35 --bundled-libraries=NONE \
36 --builtin-libraries=replace \
37 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
38 --without-gettext \
39 "
40
41PACKAGES += "python-tevent python-tevent-dbg"
42
43FILES_python-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
44FILES_python-tevent-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"