blob: c698fa04947a89c7aef91b77ea07ab212c930837 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Network Time Protocol daemon and utilities"
2DESCRIPTION = "The Network Time Protocol (NTP) is used to \
3synchronize the time of a computer client or server to \
4another server or reference time source, such as a radio \
5or satellite receiver or modem."
6HOMEPAGE = "http://support.ntp.org"
7SECTION = "net"
8LICENSE = "NTP"
9LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=e877a1d567a6a58996d2b66e3e387003"
10
11DEPENDS = "libevent"
12
13SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \
14 file://ntp-4.2.4_p6-nano.patch \
15 file://ntpd \
16 file://ntp.conf \
17 file://ntpdate \
18 file://ntpdate.default \
19 file://ntpdate.service \
20 file://ntpd.service \
21 file://sntp.service \
22 file://sntp \
23 file://ntpd.list \
24"
25
26SRC_URI[md5sum] = "00950ca2855579541896513e78295361"
27SRC_URI[sha256sum] = "f14a39f753688252d683ff907035ffff106ba8d3db21309b742e09b5c3cd278e"
28
29inherit autotools update-rc.d useradd systemd pkgconfig
30
31# The ac_cv_header_readline_history is to stop ntpdc depending on either
32# readline or curses
33EXTRA_OECONF += "--with-net-snmp-config=no \
34 --without-ntpsnmpd \
35 ac_cv_header_readline_history_h=no \
36 --with-yielding_select=yes \
37 --with-locfile=redhat \
38 --without-rpath \
39 "
40CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
41
42USERADD_PACKAGES = "${PN}"
43NTP_USER_HOME ?= "/var/lib/ntp"
44USERADD_PARAM_${PN} = "--system --home-dir ${NTP_USER_HOME} \
45 --no-create-home \
46 --shell /bin/false --user-group ntp"
47
48# NB: debug is default-enabled by NTP; keep it default-enabled here.
49PACKAGECONFIG ??= "cap debug refclocks openssl \
50 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
51"
52PACKAGECONFIG[openssl] = "--with-openssl-libdir=${STAGING_LIBDIR} \
53 --with-openssl-incdir=${STAGING_INCDIR} \
54 --with-crypto, \
55 --without-openssl --without-crypto, \
56 openssl"
57PACKAGECONFIG[cap] = "--enable-linuxcaps,--disable-linuxcaps,libcap"
58PACKAGECONFIG[readline] = "--with-lineeditlibs,--without-lineeditlibs,readline"
59PACKAGECONFIG[refclocks] = "--enable-all-clocks,--disable-all-clocks,pps-tools"
60PACKAGECONFIG[debug] = "--enable-debugging,--disable-debugging"
61PACKAGECONFIG[mdns] = "ac_cv_header_dns_sd_h=yes,ac_cv_header_dns_sd_h=no,mdns"
62PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
63
64do_install_append() {
65 install -d ${D}${sysconfdir}/init.d
66 install -m 644 ${WORKDIR}/ntp.conf ${D}${sysconfdir}
67 install -m 755 ${WORKDIR}/ntpd ${D}${sysconfdir}/init.d
68 install -d ${D}${bindir}
69 install -m 755 ${WORKDIR}/ntpdate ${D}${bindir}/ntpdate-sync
70
71 install -m 755 -d ${D}${NTP_USER_HOME}
72 chown ntp:ntp ${D}${NTP_USER_HOME}
73
74 # Fix hardcoded paths in scripts
75 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/ntpd ${D}${bindir}/ntpdate-sync
76 sed -i 's!/usr/bin/!${bindir}/!g' ${D}${sysconfdir}/init.d/ntpd ${D}${bindir}/ntpdate-sync
77 sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/ntpd ${D}${bindir}/ntpdate-sync
78 sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/ntpd ${D}${bindir}/ntpdate-sync
79 sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${bindir}/ntpdate-sync
80 sed -i '1s,#!.*perl -w,#! ${bindir}/env perl,' ${D}${sbindir}/ntptrace
81 sed -i '/use/i use warnings;' ${D}${sbindir}/ntptrace
82 sed -i '1s,#!.*perl,#! ${bindir}/env perl,' ${D}${sbindir}/ntp-wait
83 sed -i '/use/i use warnings;' ${D}${sbindir}/ntp-wait
84 sed -i '1s,#!.*perl -w,#! ${bindir}/env perl,' ${D}${sbindir}/calc_tickadj
85 sed -i '/use/i use warnings;' ${D}${sbindir}/calc_tickadj
86
87 install -d ${D}/${sysconfdir}/default
88 install -m 644 ${WORKDIR}/ntpdate.default ${D}${sysconfdir}/default/ntpdate
89 install -m 0644 ${WORKDIR}/sntp ${D}${sysconfdir}/default/
90
91 install -d ${D}/${sysconfdir}/network/if-up.d
92 ln -s ${bindir}/ntpdate-sync ${D}/${sysconfdir}/network/if-up.d
93
94 install -d ${D}${systemd_unitdir}/system
95 install -m 0644 ${WORKDIR}/ntpdate.service ${D}${systemd_unitdir}/system/
96 install -m 0644 ${WORKDIR}/ntpd.service ${D}${systemd_unitdir}/system/
97 install -m 0644 ${WORKDIR}/sntp.service ${D}${systemd_unitdir}/system/
98
99 install -d ${D}${systemd_unitdir}/ntp-units.d
100 install -m 0644 ${WORKDIR}/ntpd.list ${D}${systemd_unitdir}/ntp-units.d/60-ntpd.list
101
102 # Remove an empty libexecdir.
103 rmdir --ignore-fail-on-non-empty ${D}${libexecdir}
104}
105
106PACKAGES += "ntpdate sntp ${PN}-tickadj ${PN}-utils"
107# NOTE: you don't need ntpdate, use "ntpd -q -g -x"
108
109# ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms
110# with wonky clocks (e.g. OpenSlug)
111RDEPENDS_${PN} = "${PN}-tickadj"
112# ntpd require libgcc for execution
113RDEPENDS_${PN} += "libgcc"
114# Handle move from bin to utils package
115RPROVIDES_${PN}-utils = "${PN}-bin"
116RREPLACES_${PN}-utils = "${PN}-bin"
117RCONFLICTS_${PN}-utils = "${PN}-bin"
118
119SYSTEMD_PACKAGES = "${PN} ntpdate sntp"
120SYSTEMD_SERVICE_${PN} = "ntpd.service"
121SYSTEMD_SERVICE_ntpdate = "ntpdate.service"
122SYSTEMD_SERVICE_sntp = "sntp.service"
123
124RPROVIDES_${PN} += "${PN}-systemd"
125RREPLACES_${PN} += "${PN}-systemd"
126RCONFLICTS_${PN} += "${PN}-systemd"
127
128RPROVIDES_ntpdate += "ntpdate-systemd"
129RREPLACES_ntpdate += "ntpdate-systemd"
130RCONFLICTS_ntpdate += "ntpdate-systemd"
131
132RSUGGESTS_${PN} = "iana-etc"
133
134FILES_${PN} = "${sbindir}/ntpd.ntp ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd ${libdir} \
135 ${NTP_USER_HOME} \
136 ${systemd_unitdir}/ntp-units.d/60-ntpd.list ${libexecdir}\
137"
138FILES_${PN}-tickadj = "${sbindir}/tickadj"
139FILES_${PN}-utils = "${sbindir} ${datadir}/ntp/lib"
140RDEPENDS_${PN}-utils += "perl"
141FILES_ntpdate = "${sbindir}/ntpdate \
142 ${sysconfdir}/network/if-up.d/ntpdate-sync \
143 ${bindir}/ntpdate-sync \
144 ${sysconfdir}/default/ntpdate \
145 ${systemd_unitdir}/system/ntpdate.service \
146"
147FILES_sntp = "${sbindir}/sntp \
148 ${sysconfdir}/default/sntp \
149 ${systemd_unitdir}/system/sntp.service \
150 "
151
152CONFFILES_${PN} = "${sysconfdir}/ntp.conf"
153CONFFILES_ntpdate = "${sysconfdir}/default/ntpdate"
154
155INITSCRIPT_NAME = "ntpd"
156# No dependencies, so just go in at the standard level (20)
157INITSCRIPT_PARAMS = "defaults"
158
159pkg_postinst_ntpdate() {
160 if ! grep -q -s ntpdate $D/var/spool/cron/root; then
161 echo "adding crontab"
162 test -d $D/var/spool/cron || mkdir -p $D/var/spool/cron
163 echo "30 * * * * ${bindir}/ntpdate-sync silent" >> $D/var/spool/cron/root
164 fi
165}
166
167inherit update-alternatives
168
169ALTERNATIVE_PRIORITY = "100"
170
171ALTERNATIVE_${PN} = "ntpd"
172ALTERNATIVE_LINK_NAME[ntpd] = "${sbindir}/ntpd"