blob: 98192dc99fa734d5a9143ed80d653da172512402 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Lightweight http(s) proxy daemon"
2HOMEPAGE = "https://tinyproxy.github.io/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.gz \
7 file://disable-documentation.patch \
8 file://tinyproxy.service"
9
10SRC_URI[md5sum] = "3b60f7d08e0821ed1a3e2cf1e5778cac"
11SRC_URI[sha256sum] = "8234c879a129feee61efa98bac14a1a3e46e5cf08f01696a216940872aa70faf"
12
13EXTRA_OECONF += " \
14 --enable-filter \
15 --enable-transparent \
16 --disable-regexcheck \
17 --enable-reverse \
18 --enable-upstream \
19 --enable-xtinyproxy \
20 "
21
22inherit autotools systemd useradd
23
24#User specific
25USERADD_PACKAGES = "${PN}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040026USERADD_PARAM_${PN} = "--system --home /dev/null \
27 --no-user-group --gid nogroup tinypoxy"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028
29SYSTEMD_PACKAGES += "${BPN}"
30SYSTEMD_SERVICE_${PN} = "tinyproxy.service"
31SYSTEMD_AUTO_ENABLE_${PN} = "enable"
32
33do_install_append() {
34 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
35 install -d ${D}${systemd_system_unitdir}
36 install -m 0644 ${WORKDIR}/tinyproxy.service ${D}${systemd_system_unitdir}
37 fi
38}