blob: 51a7aa8cd34bf7ca09f6c9825a2a76c4b40eb076 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "wireshark - a popular network protocol analyzer"
2HOMEPAGE = "http://www.wireshark.org"
3SECTION = "net"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=6e271234ba1a13c6e512e76b94ac2f77"
6
7DEPENDS = "pcre expat glib-2.0 glib-2.0-native libgcrypt libgpg-error"
8
Brad Bishop2eeb5252018-09-10 18:40:16 +00009SRC_URI = "https://1.as.dl.wireshark.org/src/all-versions/${BP}.tar.xz"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010SRC_URI += "file://libgcrypt.patch"
11
12UPSTREAM_CHECK_URI = "https://1.as.dl.wireshark.org/src"
13
Armin Kuster066be202018-07-08 14:58:53 -070014SRC_URI[md5sum] = "25f93aa6a2b3fdd9d1f01a49f84d224f"
15SRC_URI[sha256sum] = "db8ed7828c157e4ffb91fb8c41fa5a2f37fd44259175951a5c37848bf641f5e8"
Brad Bishop316dfdd2018-06-25 12:45:53 -040016
17PE = "1"
18
19inherit autotools pkgconfig perlnative upstream-version-is-even
20
21ARM_INSTRUCTION_SET = "arm"
22
23PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc"
24PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}"
25
26PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_DIR_HOST}/usr, --with-libcap=no --enable-pcap-ng-default , libcap"
27PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_DIR_HOST}/usr --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap"
28PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
29PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
30PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
31PACKAGECONFIG[gtk2] = "--with-gtk=2, , gtk+"
32PACKAGECONFIG[gtk3] = "--with-gtk=3, , gtk+3"
33PACKAGECONFIG[graphics] = "--enable-wireshark, --with-gtk=no --disable-wireshark,"
34PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
35PACKAGECONFIG[ssl] = "--with-ssl=yes, --with-ssl=no, openssl"
36PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5"
37PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua"
38PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib"
39PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
40PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no"
41PACKAGECONFIG[sbc] = "--with-sbc=yes, --with-sbc=no, sbc"
42PACKAGECONFIG[libssh] = "--with-libssh=${STAGING_DIR_HOST}/usr, --with-libssh=no, libssh2"
43PACKAGECONFIG[lz4] = "--with-lz4=${STAGING_DIR_HOST}/usr, --with-lz4=no, lz4"
44
45# these next two options require addional layers
46PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
47
48EXTRA_OECONF += "--with-libgcrypt-prefix=${PKG_CONFIG_DIR} --with-qt=no --enable-tshark --enable-rawshark"
49
50LDFLAGS_append = " -lgpg-error"
51
52# Currently wireshark does not install header files
53do_install_append () {
54
55 install -d ${D}/${includedir}/${BPN}
56 install -d ${D}/${includedir}/${BPN}/epan
57 install -d ${D}/${includedir}/${BPN}/epan/crypt
58 install -d ${D}/${includedir}/${BPN}/epan/dfilter
59 install -d ${D}/${includedir}/${BPN}/epan/dissectors
60 install -d ${D}/${includedir}/${BPN}/epan/ftypes
61 install -d ${D}/${includedir}/${BPN}/epan/wmem
62
63 install config.h ${D}/${includedir}/${BPN}
64 install ${S}/register.h ${D}/${includedir}/${BPN}
65 install -D ${S}/epan/*.h ${D}/${includedir}/${BPN}/epan
66 install -D ${S}/epan/crypt/*.h ${D}/${includedir}/${BPN}/epan/crypt
67 install -D ${S}/epan/dfilter/*.h ${D}/${includedir}/${BPN}/epan/dfilter
68 install -D ${S}/epan/dissectors/*.h ${D}/${includedir}/${BPN}/epan/dissectors
69 install -D ${S}/epan/ftypes/*.h ${D}/${includedir}/${BPN}/epan/ftypes
70 install -D ${S}/epan/wmem/*.h ${D}/${includedir}/${BPN}/epan/wmem
71}
72
73FILES_${PN} += "${datadir}*"