blob: 1bad998dde828781e3b6eee7edcaa9afb3655f4f [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001# Class for use to convert all CRLF line terminators to LF
2# provided that some projects are being developed/maintained
3# on Windows so they have different line terminators(CRLF) vs
4# on Linux(LF), which can cause annoying patching errors during
5# git push/checkout processes.
6
7do_convert_crlf_to_lf[depends] += "dos2unix-native:do_populate_sysroot"
8
9# Convert CRLF line terminators to LF
10do_convert_crlf_to_lf () {
11 find ${S} -type f -exec dos2unix {} \;
12}
13
14addtask convert_crlf_to_lf after do_unpack before do_patch