blob: 67b513fa0b7a189fd955336d8afb6472f3977017 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Filesystem and hardware benchmark and stress tool"
2DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
3stress/hardware verification. It has support for a number of I/O engines, \
4I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
5and much more. It can work on block devices as well as files. fio accepts \
6job descriptions in a simple-to-understand text format. Several example job \
7files are included. fio displays all sorts of I/O performance information."
8HOMEPAGE = "http://freecode.com/projects/fio"
9SECTION = "console/tests"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
12
13DEPENDS = "libaio zlib"
14
15PACKAGECONFIG_NUMA = "numa"
16# ARM does not currently support NUMA
17PACKAGECONFIG_NUMA_arm = ""
18
19PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
20PACKAGECONFIG[numa] = ",--disable-numa,numactl"
21
Patrick Williamsddad1a12017-02-23 20:36:32 -060022# rev for v2.9
23SRCREV = "fe8d0f4c54f0c308c9a02a4e3c2f5084e8bf5461"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024SRC_URI = "git://git.kernel.dk/fio.git"
25
26S = "${WORKDIR}/git"
27
28# avoids build breaks when using no-static-libs.inc
29DISABLE_STATIC = ""
30
31EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
32
33do_configure() {
34 ./configure ${EXTRA_OECONF}
35}
36
37do_install() {
38 oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir}
39 install -d ${D}/${docdir}/${PN}
40 cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/
41}