blob: 9cc62a95918baea14cb92acea9b9712ccaf65b67 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
2SUMMARY = "EFI Boot Manager"
3HOMEPAGE = "https://github.com/rhinstaller/efibootmgr"
4SECTION = "base"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
8
9DEPENDS = "pciutils zlib efivar"
10
11COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
12
13SRCREV = "5c14da22802576a99ebb854f7aa174f796f7b031"
14SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \
15 "
16S = "${WORKDIR}/git"
17
18inherit pkgconfig
19
20EXTRA_OEMAKE = "'EFIDIR=/' 'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/include `pkg-config --cflags efivar`'"
21
22CFLAGS_append_toolchain-clang = " -Wno-error"
23do_install () {
24 install -D -p -m0755 ${B}/src/efibootmgr ${D}/${sbindir}/efibootmgr
25}
26
27CLEANBROKEN = "1"