blob: 9d4cdc97be167ad85de4be48bfb151d2072b8b7d [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhinstaller/efivar"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8DEPENDS = "popt"
9DEPENDS_append_class-target = " efivar-native"
10
11inherit pkgconfig
12
13COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
14
15SRCREV = "11324799c68193116e1dd5f94b416591bd324f90"
16SRC_URI = "git://github.com/rhinstaller/efivar.git \
17 file://allow-multi-definitions-for-native.patch \
18 file://0001-makeguids-Do-not-use-__bswap_constant_-16-32-macros.patch \
19 file://musl-strndupa.patch \
20 file://0001-efivar-dp.h-Add-Wunknown-attributes-when-using-clang.patch \
21 "
22SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch \
23 file://0003-efivar-fix-for-cross-compile.patch \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'file://0004-fix-unknow-option-for-gold-linker.patch', '', d)} \
25 "
26SRC_URI_append_class-native = " file://fix-compile-failure-with-host-gcc-4.6.patch \
27 "
28
29S = "${WORKDIR}/git"
30
31# Setting CROSS_COMPILE breaks pkgconfig, so just set AR
32EXTRA_OEMAKE = "AR=${TARGET_PREFIX}gcc-ar"
33
34do_compile_prepend() {
35 sed -i -e s:-Werror::g ${S}/gcc.specs
36}
37
38do_compile_class-native() {
39 oe_runmake -C src makeguids
40}
41
42do_install() {
43 oe_runmake install DESTDIR=${D}
44}
45
46do_install_class-native() {
47 install -D -m 0755 ${B}/src/makeguids ${D}${bindir}/makeguids
48}
49
50BBCLASSEXTEND = "native"