blob: fec380ce6f10921013118b8056682ed884e14e57 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Paho MQTT - C libraries for the MQTT and MQTT-SN protocols"
2DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)."
3HOMEPAGE = "http://www.eclipse.org/paho/"
4SECTION = "console/network"
5LICENSE = "EPL-1.0 | EDL-1.0"
6
7LIC_FILES_CHKSUM = " \
8 file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \
9 file://epl-v10;md5=659c8e92a40b6df1d9e3dccf5ae45a08 \
10 file://notice.html;md5=a00d6f9ab542be7babc2d8b80d5d2a4c \
11 file://about.html;md5=dcde438d73cf42393da9d40fabc0c9bc \
12"
13
14SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=http"
15
16SRCREV = "e8d34da24ad807f5e698b327d67591fd4b4bfa7e"
17
18DEPENDS = "openssl"
19
20S = "${WORKDIR}/git"
21
22TARGET_CC_ARCH += "${LDFLAGS}"
23
24do_install() {
25 install -d ${D}${libdir}
26 oe_libinstall -C build/output -so libpaho-mqtt3a ${D}${libdir}
27 oe_libinstall -C build/output -so libpaho-mqtt3as ${D}${libdir}
28 oe_libinstall -C build/output -so libpaho-mqtt3c ${D}${libdir}
29 oe_libinstall -C build/output -so libpaho-mqtt3cs ${D}${libdir}
30 install -d ${D}${includedir}
31 install -m 644 src/MQTTAsync.h ${D}${includedir}
32 install -m 644 src/MQTTClient.h ${D}${includedir}
33 install -m 644 src/MQTTClientPersistence.h ${D}${includedir}
34}
35