blob: bc79f356b2bfba1fbfb1f163ad38705a24554b66 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A PKCS"
2DESCRIPTION = "\
3Engine_pkcs11 is an implementation of an engine for OpenSSL. It can be \
4loaded using code, config file or command line and will pass any function \
5call by openssl to a PKCS cards and software for using smart cards in PKCS"
6HOMEPAGE = "https://github.com/OpenSC/engine_pkcs11"
7SECTION = "Development/Libraries"
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://src/engine_pkcs11.h;beginline=1;endline=26;md5=973a19f8a6105de047f2adfbbfc04c33"
10DEPENDS = "openssl libp11"
11
12SRC_URI = "git://github.com/OpenSC/engine_pkcs11.git"
13SRCREV = "132fcf2c8b319f9f4b2ebdc8dcb54ff496dc0519"
14
15S = "${WORKDIR}/git"
16
17inherit autotools pkgconfig
18
19EXTRA_OECONF = "\
20 --disable-static \
21 --libdir ${libdir}/engines \
22"
23
24do_install_append () {
25 rm -f ${D}${libdir}/engines/libpkcs11.la
26}
27
28FILES_${PN} += "${libdir}/engines/libpkcs11${SOLIBSDEV}"
29FILES_${PN}-dbg += "${libdir}/engines/.debug/"
30
31RDEPENDS_${PN} += "openssl libp11 opensc"