blob: 7a70f7576363f0c9a717b6a53553d3088929b981 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)"
2DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \
3from the CPUID instruction, and also determines the exact model of CPU(s). \
4It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \
5UMC, NexGen, Rise, and SiS CPUs"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz"
10SRC_URI[md5sum] = "1c46a6662626c5a6eaca626f23a5a7d7"
11SRC_URI[sha256sum] = "667612aae6704341dd10844e97c84c5c5c8700817a5937a3c293b55013bc4865"
12
13COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
14
15# The install rule from the Makefile has hardcoded paths, so we duplicate
16# the actions to accommodate different paths.
17do_install () {
18 install -d -m755 ${D}/${bindir}
19 install -m755 ${B}/cpuid ${D}/${bindir}/cpuid
20 install -d -m755 ${D}/${mandir}
21 install -m444 ${B}/cpuid.man.gz ${D}/${mandir}
22}