blob: 90524974ba99778ca5a4ac51e4f7399b2871f568 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "The Mercurial distributed SCM"
2HOMEPAGE = "http://mercurial.selenic.com/"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6DEPENDS = "python python-native"
7DEPENDS_class-native = "python-native"
8RDEPENDS_${PN} = "python python-modules"
9
10inherit python-dir
11
12SRC_URI = "https://www.mercurial-scm.org/release/${BP}.tar.gz"
13SRC_URI[md5sum] = "c1d9fad1b7ed7077b0d4ae82e71154db"
14SRC_URI[sha256sum] = "234af4a67565c85923b0a1910c704ab44bcf12f69b85532687208776563d87de"
15
16S = "${WORKDIR}/mercurial-${PV}"
17
18BBCLASSEXTEND = "native"
19
20EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
21 PREFIX=${prefix}"
22
23do_configure_append () {
24 sed -i -e 's:PYTHON=python:PYTHON=${STAGING_BINDIR_NATIVE}/python-native/python:g' ${S}/Makefile
25}
26
27do_install () {
28 oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix}
29}
30
31FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"