blob: fe1e6e5faffbbad16e3312cc3b8b7581346496f7 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
2DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \
3serialization format. It includes libprotobuf-c, a pure C library that \
4implements protobuf encoding and decoding, and protoc-c, a code generator that \
5converts Protocol Buffer .proto files to C descriptor code, based on the \
6original protoc. protobuf-c formerly included an RPC implementation; that code \
7has been split out into the protobuf-c-rpc project."
8HOMEPAGE = "https://github.com/protobuf-c/protobuf-c"
9SECTION = "console/tools"
10LICENSE = "BSD-2-Clause"
11
12DEPENDS = "protobuf-native protobuf"
13
14PACKAGE_BEFORE_PN = "${PN}-compiler"
15RDEPENDS_${PN}-compiler = "protobuf-compiler"
16RDEPENDS_${PN}-dev += "${PN}-compiler"
17
18LIC_FILES_CHKSUM = "file://LICENSE;md5=cb901168715f4782a2b06c3ddaefa558"
19
20PV .= "+git${SRCPV}"
21SRCREV = "dac1a65feac4ad72f612aab99f487056fbcf5c1a"
22
23SRC_URI = "git://github.com/protobuf-c/protobuf-c.git"
24
25S = "${WORKDIR}/git"
26
27inherit autotools pkgconfig
28
29FILES_${PN}-compiler = "${bindir}"
30
31BBCLASSEXTEND = "native nativesdk"