blob: ab65ba1dcf72bf8333ef781af06b0b42dc1f0c91 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Python GObject bindings"
2HOMEPAGE = "http://www.pygtk.org/"
3SECTION = "devel/python"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
6
7inherit autotools pkgconfig gnomebase distutils-base gobject-introspection
8
9PYTHON_BASEVERSION = "2.7"
10PYTHON_PN = "python"
11
12DEPENDS += "gnome-common-native python glib-2.0"
13
14SRCNAME="pygobject"
15SRC_URI = " \
16 http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
17 file://0001-configure.ac-add-sysroot-path-to-GI_DATADIR-don-t-se.patch \
18"
19
20SRC_URI[md5sum] = "b29d69edb63ae1f555afeb19f90b9996"
21SRC_URI[sha256sum] = "42b47b261b45aedfc77e02e3c90a01cd74d6f86c3273c1860a054d531d606e5a"
22
23S = "${WORKDIR}/${SRCNAME}-${PV}"
24
25BBCLASSEXTEND = "native"
26
27EXTRA_OECONF = "--disable-cairo --with-python=${PYTHON}"
28
29RDEPENDS_${PN} += "python-setuptools"
30RDEPENDS_${PN}_class-native = ""
31
32do_install_append() {
33 # Remove files that clash with python3-pygobject; their content is same
34 rm -rf ${D}${includedir}/pygobject-3.0//pygobject.h ${D}${libdir}/pkgconfig
35}