blob: 99b43fa3f84fcc04907616f7e471818cd46630f6 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# Copyright (C) 2016 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Open-source software for volunteer computing"
5DESCRIPTION = "The Berkeley Open Infrastructure for Network Computing (BOINC) is an open- \
6source software platform which supports distributed computing, primarily in \
7the form of volunteer computing and desktop Grid computing. It is well \
8suited for problems which are often described as trivially parallel. BOINC \
9is the underlying software used by projects such as SETI@home, Einstein@Home, \
10ClimatePrediciton.net, the World Community Grid, and many other distributed \
11computing projects. \
12This package installs the BOINC client software, which will allow your \
13computer to participate in one or more BOINC projects, using your spare \
14computer time to search for cures for diseases, model protein folding, study \
15global warming, discover sources of gravitational waves, and many other types \
16of scientific and mathematical research."
17
18HOMEPAGE = "http://boinc.berkeley.edu/"
19LICENSE = "LGPLv2+ & GPLv3"
20LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
21 file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6"
22SECTION = "applications"
23DEPENDS = "curl \
24 jpeg \
25 openssl \
26 sqlite3 \
27 virtual/libgl \
28 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libnotify', '', d)} \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+ libnotify xcb-util libxscrnsaver', '', d)} \
30 nettle \
31"
32
33SRC_URI = "https://github.com/BOINC/boinc/archive/client_release/7.6/${PV}.tar.gz \
34 file://boinc-AM_CONDITIONAL.patch \
35 file://opengl_m4_check.patch \
36 file://cross-compile.patch \
37 file://gtk-configure.patch \
38"
39SRC_URI[md5sum] = "437b4b98e384b4bda4ef7056e68166ac"
40SRC_URI[sha256sum] = "c4b1c29b9655013e0ac61dddf47ad7f30f38c46159f02a9d9dc8ab854e99aa6d"
41
Brad Bishopd7bf8c12018-02-25 22:55:05 -050042inherit gettext autotools-brokensep pkgconfig distro_features_check
43
44REQUIRED_DISTRO_FEATURES += "opengl"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050045
46S = "${WORKDIR}/${BPN}_release-7.6-${PV}"
47
48EXTRA_OECONF += "\
49 --enable-libraries \
50 --enable-unicode \
51 --enable-shared \
52 --enable-dynamic-client-linkage \
53 --enable-client \
54 --disable-server \
55 --disable-static \
56 --disable-manager \
57 --with-ssl=${STAGING_EXECPREFIXDIR} \
58 --without-wxdir \
59 --without-x \
60 --with-boinc-platform=${TARGET_SYS} \
61"
62export PKG_CONFIG = "${STAGING_BINDIR_NATIVE}/pkg-config"
63
64do_configure_prepend () {
65 if "${@bb.utils.contains('DEPENDS', 'gtk+', '1', '0', d)}" = "0"
66 then
67 export GTK2_CFLAGS=""
68 export GTK2_LIBS=""
69 fi
70}
71
72do_compile_prepend () {
73 # Disable rpaths
74 sed -i -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${B}/${TARGET_SYS}-libtool
75 sed -i -e 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec=""|g' ${B}/${TARGET_SYS}-libtool
76 sed -i -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${B}/${TARGET_SYS}-libtool
77}
78
79SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"