blob: b52e7cc0823b90ab510e247eda335c183c970a9d [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001#
2# Copyright (C) 2014 - 2017 Wind River Systems, Inc.
3#
4SUMMARY = "Base policy for CFEngine"
5
6DESCRIPTION = "CFEngine is an IT infrastructure automation framework \
7that helps engineers, system administrators and other stakeholders \
8in an IT system to manage and understand IT infrastructure throughout \
9its lifecycle. CFEngine takes systems from Build to Deploy, Manage and Audit. \
10 \
11This package is intended to provide a stable base policy for \
12installations and upgrades, and is used by CFEngine 3.6 and newer. \
13 \
14The contents of this packge are intended to live in `/var/cfengine/masterfiles` \
15or wherever `$(sys.masterdir)` points. \
16"
17
18HOMEPAGE = "http://cfengine.com"
19
20LICENSE = "MIT"
21LIC_FILES_CHKSUM = "file://LICENSE;md5=9f76426f9ef8c6f6739fadd21d817a4f"
22
23SRC_URI = "https://cfengine-package-repos.s3.amazonaws.com/tarballs/${BP}.tar.gz"
24
25SRC_URI[md5sum] = "1247ef4e8f3cee5efa98da50c326e5a4"
26SRC_URI[sha256sum] = "5d18a8d71f451d0b5dd1f5e579452b29b99b664f2bb0827dbba9a615f2764df6"
27
28inherit autotools
29
30export EXPLICIT_VERSION="${PV}"
31
32EXTRA_OECONF = "--prefix=${datadir}/cfengine"
33
34FILES_${PN} = "${datadir}/cfengine"
35
36RDEPENDS_${PN} += "python-core"