blob: f2c661c8f74647a635da9188279fa9a346d2e1ed [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Libraries providing API for reporting different problems in applications \
2to different bug targets like Bugzilla, ftp, trac, etc..."
3SUMMARY = "Generic library for reporting various problems"
4HOMEPAGE = "https://abrt.readthedocs.org/"
5LICENSE = "GPLv2+"
6DEPENDS = "xmlrpc-c xmlrpc-c-native intltool-native \
7 json-c libtar libnewt libproxy rpm \
Brad Bishop316dfdd2018-06-25 12:45:53 -04008 augeas satyr systemd \
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
12
13
14SRC_URI = "git://github.com/abrt/libreport.git;protocol=https"
15SRC_URI += "file://0001-Makefile.am-remove-doc-and-apidoc.patch \
16 file://0002-configure.ac-remove-prog-test-of-xmlto-and-asciidoc.patch \
17 file://0003-without-build-plugins.patch \
18 file://0004-configure.ac-remove-prog-test-of-augparse.patch \
19 file://0005-remove-python2-support.patch \
20"
21SRCREV = "cfff49f06d9d17e269d463ee71b3d94c8bfb0c58"
22S = "${WORKDIR}/git"
23
24inherit distro_features_check
25REQUIRED_DISTRO_FEATURES = "systemd"
26
27inherit gettext autotools python3native pkgconfig
28
Brad Bishop316dfdd2018-06-25 12:45:53 -040029PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','x11','gtk','',d)}"
30PACKAGECONFIG[gtk] = "--with-gtk, --without-gtk, gtk+3,"
31
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032RDEPENDS_python3-libreport += "${PN}"
33
34do_patch[prefuncs] += "do_gen_version"
35do_gen_version() {
36 cd ${S}
37 ./gen-version
38}
39
40PACKAGES += "python3-libreport"
41
42FILES_${PN} += "${datadir}/*"
43FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug"
44FILES_python3-libreport = "${PYTHON_SITEPACKAGES_DIR}/*"
45