blob: f618f02b5dbe21140b72361b7950b0895f10f3f2 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Opensource Implementation of WS-Management"
2DESCRIPTION = "Openwsman is a project intended to provide an open-source \
3implementation of the Web Services Management specipication \
4(WS-Management) and to expose system management information on the \
5Linux operating system using the WS-Management protocol. WS-Management \
6is based on a suite of web services specifications and usage \
7requirements that exposes a set of operations focused on and covers \
8all system management aspects. \
9Openwsman Server and service libraries"
10HOMEPAGE = "http://www.openwsman.org/"
11SECTION = "Applications/System"
12
13DEPENDS = "curl libxml2 openssl libpam"
14
Brad Bishop316dfdd2018-06-25 12:45:53 -040015inherit distro_features_check
16REQUIRED_DISTRO_FEATURES = "pam"
17
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018SRCREV = "feb7ec9b004fcaea0dbe65ce8a1a79cc29dd994c"
19PV = "2.6.3"
20
21SRC_URI = "git://github.com/Openwsman/openwsman.git \
22 file://libssl-is-required-if-eventint-supported.patch \
23 file://openwsmand.service \
24 file://0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch \
25 "
26
27S = "${WORKDIR}/git"
28
29LICENSE = "BSD"
30LIC_FILES_CHKSUM = "file://COPYING;md5=d4f53d4c6cf73b9d43186ce3be6dd0ba"
31
32inherit systemd cmake pkgconfig pythonnative perlnative
33
34SYSTEMD_SERVICE_${PN} = "openwsmand.service"
35SYSTEMD_AUTO_ENABLE = "disable"
36
37LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}"
38
39EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
40 -DBUILD_LIBCIM=NO \
41 -DBUILD_PERL=YES \
42 -DCMAKE_INSTALL_PREFIX=${prefix} \
43 -DLIB=${baselib} \
44 "
45
46do_configure_prepend() {
47 export STAGING_INCDIR=${STAGING_INCDIR}
48 export STAGING_LIBDIR=${STAGING_LIBDIR}
49}
50
51do_install_append() {
52 install -d ${D}/${sysconfdir}/init.d
53 install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand
54 ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand
55 chmod 755 ${D}/${sysconfdir}/openwsman/owsmangencert.sh
56 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
57 install -d ${D}/${systemd_unitdir}/system
58 install -m 644 ${WORKDIR}/openwsmand.service ${D}/${systemd_unitdir}/system
59
60 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/openwsmand.service
61 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/openwsmand.service
62 sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${systemd_unitdir}/system/openwsmand.service
63 fi
64}
65
66FILES_${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \
67 ${libdir}/openwsman/authenticators/.debug/ \
68 "
69
70INSANE_SKIP_${PN} = "dev-so"