blob: febf3f256dbd311274ad472aff326048af7d217c [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "The volume_key project provides a libvolume_key, a library for manipulating \
2storage volume encryption keys and storing them separately from volumes, and an \
3associated command-line tool, named volume_key."
4LICENSE = "GPLv2"
5SECTION = "devel/lib"
6
7HOMEPAGE = "https://pagure.io/volume_key"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
11SRC_URI = "https://releases.pagure.org/volume_key/volume_key-${PV}.tar.xz \
12 file://0001-explicitly-support-python3-by-pkg-config.patch \
13"
14SRC_URI[md5sum] = "a2d14931177c660e1f3ebbcf5f47d8e2"
15SRC_URI[sha256sum] = "450a54fe9bf56acec6850c1e71371d3e4913c9ca1ef0cdc3a517b4b6910412a6"
16
17SRCNAME = "volume_key"
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit autotools python3native gettext
21
22DEPENDS += " \
23 util-linux \
24 glib-2.0 \
25 cryptsetup \
26 nss \
27 gpgme \
28"
29
30RDEPENDS_python3-${PN} += "${PN}"
31
32PACKAGES += "python3-${PN}"
33FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
34