blob: 8d3c578d0d6983799c1a0d5e665bdbc94805e66d [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Convert text file line endings between CRLF and LF"
2DESCRIPTION = "The Dos2unix package includes utilities dos2unix and \
3unix2dos to convert plain text files in DOS or Mac format to Unix \
4format and vice versa."
5HOMEPAGE = "http://waterlan.home.xs4all.nl/dos2unix.html"
6SECTION = "support"
7
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://COPYING.txt;md5=1b78fca784db24f4a40e30b300787f3f"
10
11SRC_URI = "git://git.code.sf.net/p/dos2unix/dos2unix"
12
13# Release 7.4.0
14SRCREV = "1182533bde3c1fe65be2ead465e87671faa2c027"
15
16S = "${WORKDIR}/git/dos2unix"
17
18inherit gettext perlnative
19
20# The dos2unix NLS relies on po4a-native, while po4a recipe is
21# provided by meta-perl layer, so make it optional here, you
22# need have meta-perl in bblayers.conf before enabling nls in
23# PACKAGECONFIG.
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[nls] = "ENABLE_NLS=1,ENABLE_NLS=,po4a-native"
26
27EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} LDFLAGS_USER='${LDFLAGS}'"
28EXTRA_OEMAKE_class-native = "ENABLE_NLS="
29
30do_install () {
31 oe_runmake DESTDIR="${D}${base_prefix}" install
32}
33
34BBCLASSEXTEND = "native nativesdk"