blob: 48c8221a3bf063c1ea6b25ec5c1f21abb772b6e3 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Interactive Connectivity Establishment library"
2DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactive Connectivity Establishment standard (ICE)."
3HOMEPAGE = "http://nice.freedesktop.org/wiki/"
4SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz"
5SRC_URI[md5sum] = "3226faeaf48a9150ada00da2e2865959"
6SRC_URI[sha256sum] = "61112d9f3be933a827c8365f20551563953af6718057928f51f487bfe88419e1"
7
8LICENSE = "LGPLv2.1 & MPLv1.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=9c42325015702feda4f4d2f19a55b767 \
10 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
11 file://COPYING.MPL;md5=3c617710e51cdbe0fc00716f056dfb1a \
12"
13
14DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base"
15
16PACKAGECONFIG ??= ""
17PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd"
18
19inherit autotools pkgconfig gtk-doc gobject-introspection
20
21FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
22FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la"
23FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
24FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
25
26do_configure_prepend() {
27 mkdir ${S}/m4 || true
28}
29
30do_compile_append() {
31 for i in $(find ${B} -name "*.pc") ; do
32 sed -i -e s:${STAGING_DIR_TARGET}::g \
33 -e s:/${TARGET_SYS}::g \
34 $i
35 done
36}