blob: 6903021490f5b65eed6227032eec9be1c1be2eec [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "The goal of this project is to provide a tiny library that would \
2facilitate the common operations with sizes in bytes."
3HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
4LICENSE = "LGPLv2+"
5SECTION = "devel/lib"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
8
9S = "${WORKDIR}/git"
10B = "${S}"
11
12SRCREV = "369127c0edbba7d1a4e2e02486375dd9d379524f"
13PV = "0.10+git${SRCPV}"
14SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master \
15 file://0001-remove-python2-support.patch \
16"
17
18inherit gettext autotools python3native
19
20DEPENDS += " \
21 libpcre \
22 gmp \
23 mpfr \
24"
25
26FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
27
28PACKAGECONFIG ??= "python3"
29PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
30PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
31
32EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"
33
34