blob: 0930a277bccc67a57044067c74bf9bab983cf3f7 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9331186f4f80db7da0e724bdd6554ee5"
5SECTION = "net"
6DEPENDS = "libgcrypt gnutls file"
7
8SRC_URI = "http://ftp.gnu.org/gnu/libmicrohttpd/${BPN}-${PV}.tar.gz"
9SRC_URI[md5sum] = "1c20f84a8b9cf692dd50b558b3571a3a"
10SRC_URI[sha256sum] = "0c1cab8dc9f2588bd3076a28f77a7f8de9560cbf2d80e53f9a8696ada80ed0f8"
11
12inherit autotools lib_package pkgconfig gettext
13
Brad Bishop316dfdd2018-06-25 12:45:53 -040014CFLAGS += "-pthread -D_REENTRANT"
15
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
17
18PACKAGECONFIG ?= "curl"
19PACKAGECONFIG_append_class-target = "\
20 ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
21"
22PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
23PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
24
25do_compile_append() {
26 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
27}