blob: 84633a76c9986b74d8ae01ce81e27fd757d6e323 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
2DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
3and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
4and should run on all Linux systems that need error handling."
5HOMEPAGE = "http://mcelog.org/"
6SECTION = "System Environment/Base"
7
8SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \
9 file://run-ptest \
10"
11
12SRCREV = "2cfdf29b2ef98ccd5ed42cdde8bbe437e0d6412f"
13
14LICENSE = "GPLv2"
15LIC_FILES_CHKSUM = "file://README.md;md5=279840fabb191e6cd9150492d31b0e20"
16
17S = "${WORKDIR}/git"
18
19inherit autotools-brokensep ptest
20
21COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
22
23do_install_append() {
24 install -d ${D}${sysconfdir}/cron.hourly
25 install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
26 sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
27}
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}
31 cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
32 sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
33}
34
35RDEPENDS_${PN}-ptest += "${PN} make bash mce-inject"