blob: f795c3717b66339bbae3c658080e604e4c016fb2 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
2failure processing, analysis, and reporting supporting kernel space, user \
3space, Python, and Java programs"
4
5HOMEPAGE = "https://github.com/abrt/satyr"
6LICENSE = "GPLv2"
7
8inherit autotools-brokensep python3native pkgconfig
9
10SRC_URI = "git://github.com/abrt/satyr.git \
11 file://0001-do-not-support-python2.patch \
12 file://0002-fix-compile-failure-against-musl-C-library.patch \
13"
14SRCREV = "4742fd4857c446b96f712d52e2e4cd0b6cfe7398"
15S = "${WORKDIR}/git"
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
18
19DEPENDS += " \
20 gdb \
21"
22
23PACKAGES += "python3-${PN}"
24FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
25
26PACKAGECONFIG ??= "python3 rpm"
27PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
28PACKAGECONFIG[pythonmanpage] = "--enable-python-manpage, --disable-python-manpage"
29PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
30
31do_configure_prepend() {
32 ${S}/gen-version
33}