blob: 7fab43025f72ad59fc9c86d573f5051978961b10 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "A tool to load and stress a computer system"
2HOMEPAGE = "http://kernel.ubuntu.com/~cking/stress-ng/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6DEPENDS = "zlib libaio"
7
8SRC_URI = "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
9 file://0002-stress-fcntl-fix-build-for-musl.patch \
10 "
11SRC_URI_append_libc-musl = " \
12 file://0001-Several-changes-to-fix-musl-build.patch \
13 "
14SRC_URI[md5sum] = "1f8b6c2c2830704d2a2814c16082d48e"
15SRC_URI[sha256sum] = "02cac34a5cb041197af60c1867844c6cbb089a6d10a38cdcf7b8f27bfaa6ef8f"
16
17UPSTREAM_CHECK_URI ?= "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/"
18UPSTREAM_CHECK_REGEX ?= "(?P<pver>\d+(\.\d+)+)\.tar"
19
20CFLAGS += "-Wall -Wextra -DVERSION='"$(VERSION)"'"
21
22do_install_append() {
23 install -d ${D}${bindir}
24 install -m 755 ${S}/stress-ng ${D}${bindir}/stress-ng
25}