blob: b8766a7c7f08d4ed42b9f05f9f80bdbf0231cf6a [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Analyzes log files and sends noticeable events as email"
2DESCRIPTION = "\
3Logcheck is a simple utility which is designed to allow a system administrator \
4to view the log-files which are produced upon hosts under their control. \
5It does this by mailing summaries of the log-files to them, after first \
6filtering out "normal" entries. \
7Normal entries are entries which match one of the many included regular \
8expression files contain in the database."
9SECTION = "Applications/System"
10HOMEPAGE = "http://logcheck.org/"
11LICENSE = "GPLv2"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=c93c0550bd3173f4504b2cbd8991e50b"
13
14SRC_URI = "git://git.debian.org/git/logcheck/logcheck.git \
15 file://99_logcheck \
16"
17SRCREV = "0a5865d80fa34c55387a1917a3e6f885bcff7f1d"
18
19S = "${WORKDIR}/git"
20
21inherit useradd
22
23USERADD_PACKAGES = "${PN}"
24USERADD_PARAM_${PN} = "-m -g ${BPN} -G adm -r -d ${localstatedir}/lib/${BPN} \
25 -s /bin/false -c 'logcheck account' ${BPN}"
26GROUPADD_PARAM_${PN} = "-r ${BPN}"
27
28do_install() {
29 # Fix QA Issue
30 sed -i '/install -d $(DESTDIR)\/var\/lock\/logcheck/s/^/#/' Makefile
31
32 # "make install" do not install the manpages. Install them manually.
33 install -m 755 -d ${D}${mandir}/man1
34 install -m 755 -d ${D}${mandir}/man8
35 install -m 644 docs/logcheck-test.1 ${D}${mandir}/man1/
36 install -m 644 docs/logtail.8 ${D}${mandir}/man8/
37 install -m 644 docs/logtail2.8 ${D}${mandir}/man8/
38
39 install -m 755 -d ${D}${sysconfdir}/cron.d
40 install -m 644 debian/logcheck.cron.d ${D}${sysconfdir}/cron.d/logcheck
41 install -m 755 -d ${D}/var/lib/logcheck
42
43 oe_runmake install DESTDIR=${D}
44
45 # install header.txt for generated mails
46 install -m 0644 ${S}/debian/header.txt ${D}${sysconfdir}/${BPN}
47
48 chown -R ${BPN}:${BPN} ${D}${localstatedir}/lib/${BPN}
49 chown -R root:${BPN} ${D}${sysconfdir}/${BPN}
50
51 # Don't install /var/lock when populating rootfs. Do it through volatile
52 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
53 install -d ${D}${sysconfdir}/default/volatiles
54 install -m 0644 ${WORKDIR}/99_logcheck ${D}${sysconfdir}/default/volatiles
55 fi
56 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
57 install -d ${D}${sysconfdir}/tmpfiles.d
58 echo "d /var/lock/logcheck 0755 logcheck logcheck -" \
59 > ${D}${sysconfdir}/tmpfiles.d/logcheck.conf
60 fi
61}
62
63VIRTUAL-RUNTIME_syslog ??= "rsyslog"
64
65RDEPENDS_${PN} = "\
66 bash \
67 cronie \
68 debianutils-run-parts \
69 grep \
70 lockfile-progs \
71 mime-construct \
72 perl \
73 perl-module-file-basename \
74 perl-module-getopt-std \
75 perl-module-file-glob \
76 ${VIRTUAL-RUNTIME_syslog} \
77"
78
79FILES_${PN} += "${datadir}/logtail"