blob: cfecef9cfd63c042353d91605c0fda067b771f50 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Net::SSLeay - Perl extension for using OpenSSL"
2DESCRIPTION = "This module offers some high level convenience functions for accessing \
3web pages on SSL servers (for symmetry, same API is offered for \
4accessing http servers, too), a sslcat() function for writing your own \
5clients, and finally access to the SSL api of SSLeay/OpenSSL package \
6so you can write servers or clients for more complicated applications."
7HOMEPAGE = "http://search.cpan.org/dist/Net-SSLeay/"
8SECTION = "libs"
9
10LICENSE = "Artistic-1.0 | GPL-1.0+"
11LIC_FILES_CHKSUM = "file://README;beginline=274;endline=294;md5=67d67095d83e339da538a082fad5f38e"
12
13DEPENDS = "openssl zlib openssl-native"
14RDEPENDS_${PN} += "\
15 libssl \
16 libcrypto \
17 perl-module-carp \
18 perl-module-errno \
19 perl-module-extutils-makemaker \
20 perl-module-mime-base64 \
21 perl-module-socket \
22 zlib \
23"
24
25SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \
26 file://run-ptest \
27 "
28SRC_URI[md5sum] = "cfbe968487149626978f427cc9fb8c77"
29SRC_URI[sha256sum] = "823ec3cbb428309d6a9e56f362a9300693ce3215b7fede109adb7be361fff177"
30
31S = "${WORKDIR}/Net-SSLeay-${PV}"
32
33inherit cpan ptest
34
35export OPENSSL_PREFIX="${STAGING_LIBDIR}"
36
37EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS='-L${STAGING_LIBDIR} -lcrypto -lssl -L${STAGING_BASELIBDIR} -lz'"
38
39do_install_ptest() {
40 cp -r ${B}/t ${D}${PTEST_PATH}
41}
42
43BBCLASSEXTEND = "native"
44
45FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Net/SSLeay/.debug/"
46
47RDEPENDS_${PN}-ptest = " perl"