blob: 961436f5335cbec947fce02bff75fd3ac67a6701 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Backport of functools.lru_cache from Python 3.3"
2HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=47;endline=47;md5=98fc3658e5970d26f6b2109808c766be"
6
7PYPI_PACKAGE = "backports.functools_lru_cache"
8
9SRC_URI[md5sum] = "b954e7d5e2ca0f0f66ad2ed12ba800e5"
10SRC_URI[sha256sum] = "31f235852f88edc1558d428d890663c49eb4514ffec9f3650e7f3c9e4a12e36f"
11
12DEPENDS += "python-setuptools-scm-native"
13
14inherit setuptools pypi
15
16RDEPENDS_${PN} += "\
17 ${PYTHON_PN}-pickle \
18 ${PYTHON_PN}-threading \
19 "