blob: 0f18ccc88146d5d9fba8e79ffc55b0982f3cb9eb [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT & AFL-2.1 | GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4 \
6 file://dbus-gmain/COPYING;md5=05c3eacd50f69bb1d58afec460baad57 "
7DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
8
9SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
10"
11
12SRC_URI[md5sum] = "1ce1ddf2582060f8f971652ea54cc17e"
13SRC_URI[sha256sum] = "32f29c17172cdb9cb61c68b1f1a71dfe7351506fc830869029c47449bd04faeb"
14S = "${WORKDIR}/dbus-python-${PV}"
15
16inherit distutils-base autotools pkgconfig
17
18PACKAGECONFIG ?= ""
19PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python3-docutils-native"
20PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python3-docutils-native python3-epydoc-native"
21
22export STAGING_LIBDIR
23export STAGING_INCDIR
24
25RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
26
27FILES_${PN}-dev += "${libdir}/pkgconfig"
28
29do_install_append() {
30 # Remove files that clash with python3-dbus; their content is same
31 rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc
32}