blob: bec9d846b563342cdb375b3ab1e6f80cafcd2e8c [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "Google gRPC"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5DEPENDS = "python-protobuf"
6
7SRC_URI_append_class-target = " file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch "
8
9RDEPENDS_${PN} = "python-enum34 \
10 python-futures \
11 python-protobuf \
12 python-setuptools \
13 python-six \
14"
15
16LICENSE = "BSD-3-Clause"
17LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
18
19inherit pypi setuptools
20
21SRC_URI[md5sum] = "7860f7c61de3890323670b7b1ff63e56"
22SRC_URI[sha256sum] = "88d87aab9c7889b3ab29dd74aac1a5493ed78b9bf5afba1c069c9dd5531f951d"
23
24# For usage in other recipes when compiling protobuf files (e.g. by grpcio-tools)
25BBCLASSEXTEND = "native"