blob: 5de83ce4878683f994b9699d5fcdc301162c85c2 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Control process attributes through prctl"
2DESCRIPTION = "The linux prctl function allows you to control specific characteristics of a \
3process' behaviour. Usage of the function is fairly messy though, due to \
4limitations in C and linux. This module provides a nice non-messy python(ic) \
5interface."
6SECTION = "devel/python"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5eb2f4bcd60326f83e5deb542372d52f"
9
10S = "${WORKDIR}/git"
11B = "${S}"
12
13SRCREV = "1107d0be7bec4b28c85c62c454882d16844c930a"
14PV = "1.6.1+git${SRCPV}"
15
16SRC_URI = "git://github.com/seveas/python-prctl;branch=master \
17 file://0001-support-cross-complication.patch \
18"
19inherit setuptools3 python3native
20
21DEPENDS += "libcap"
22