blob: 46dc32de763991a872d06ba9b7e934dc903fc843 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "A python module for system storage configuration"
2HOMEPAGE = "http://fedoraproject.org/wiki/blivet"
3LICENSE = "LGPLv2+"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9B = "${S}"
10
11SRCREV = "39db82f20d8d4904c0c4dc8912e595177c59e091"
12SRC_URI = "git://github.com/rhinstaller/blivet;branch=2.2-devel \
13 file://0001-comment-out-selinux.patch \
14 file://0002-run_program-support-timeout.patch\
15 file://0003-support-infinit-timeout.patch \
16 file://0004-Mount-var-volatile-during-install.patch \
17 file://0005-update-fstab-by-appending.patch \
18 file://0006-fix-new.roots-object-is-not-iterable.patch \
19 file://0007-fix-incorrect-timeout-while-system-time-changed.patch \
20 file://0008-tweak-btrfs-packages.patch \
21 file://0009-invoking-mount-with-infinite-timeout.patch \
22 file://0010-use-oe-variable-to-replace-hardcoded-dir.patch \
23 file://0011-invoking-fsck-with-infinite-timeout.patch \
24 file://0012-invoking-mkfs-with-infinite-timeout.patch \
25 file://0013-Revert-Adapt-to-logging-module-name-change.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040026 file://0014-invoking-dd-with-infinite-timeout.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050027"
28
29inherit distro_features_check
30REQUIRED_DISTRO_FEATURES = "systemd"
31
32inherit setuptools3 python3native
33
34RDEPENDS_${PN} = "python3-pykickstart python3-pyudev \
35 parted python3-pyparted multipath-tools \
36 lsof cryptsetup libblockdev \
37 libbytesize \
38"
39
40FILES_${PN} += " \
41 ${datadir}/dbus-1/system-services \
42"
43
44inherit systemd
45
46SYSTEMD_AUTO_ENABLE = "disable"
47SYSTEMD_SERVICE_${PN} = "blivet.service"