blob: 28c2565a1451a927cd302a219d59ea7e1204d8b3 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "GUI tool for storage configuration using blivet library"
2HOMEPAGE = "https://github.com/rhinstaller/blivet-gui"
3LICENSE = "GPLv2+"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9B = "${S}"
10
11SRCREV = "52ae8c000843c05abd1d8749f44bbe2e5d891d3d"
12SRC_URI = "git://github.com/rhinstaller/blivet-gui;branch=master \
13"
14
15inherit distro_features_check
Brad Bishop316dfdd2018-06-25 12:45:53 -040016REQUIRED_DISTRO_FEATURES = "x11 systemd"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
18inherit setuptools3 python3native
19
20RDEPENDS_${PN} = "python3-pygobject python3 \
21 python3-blivet gtk+3 \
22 python3-pid libreport \
23"
24
25FILES_${PN} += " \
26 ${datadir}/* \
27 "