blob: 7f1986e5160f8f78c7619398fca7eee598952024 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Python WBEM Client and Provider Interface"
2DESCRIPTION = "\
3A Python library for making CIM (Common Information Model) operations over \
4HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \
5WBEM client should be easy to use and not necessarily require a large amount \
6of programming knowledge. It is suitable for a large range of tasks from \
7simply poking around to writing web and GUI applications. \
8\
9WBEM, or Web Based Enterprise Management is a manageability protocol, like \
10SNMP, standardised by the Distributed Management Task Force (DMTF) available \
11at http://www.dmtf.org/standards/wbem. \
12\
13It also provides a Python provider interface, and is the fastest and easiest \
14way to write providers on the planet."
15HOMEPAGE = "http://pywbem.sf.net/"
16LICENSE = "LGPLv2"
17LIC_FILES_CHKSUM = "file://pywbem/LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
18SECTION = "Development/Libraries"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019DEPENDS = "python-m2crypto-native python-typing-native"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020SRC_URI = "http://jaist.dl.sourceforge.net/project/${BPN}/${BPN}/${BP}/${BP}-dev.r704.zip"
21SRC_URI[md5sum] = "84072451dcdd1aa9ee82363848faf7ad"
22SRC_URI[sha256sum] = "898035866d3cc741bbcd62c4ac26e633ad07b7c11d89db2472b9f923f3fd3ed8"
23
24S = "${WORKDIR}/${BP}-dev"
25
26inherit setuptools python-dir
27
28do_install_append() {
29 mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli
30 mv ${D}${bindir}/mof_compiler.py ${D}${bindir}/mofcomp
31
32 rm ${D}${libdir}/python2.7/site-packages/${BPN}/wbemcli.py*
33 rm ${D}${libdir}/python2.7/site-packages/${BPN}/mof_compiler.py*
34}
35
36BBCLASSEXTEND = "native"